Install Strawberry Fields

Strawberry Fields supports Python 3.5 or newer.

If you currently do not have Python 3 installed, we recommend Anaconda for Python 3, a distributed version of Python packaged for scientific computation.

                
# install the latest released version of Strawberry Fields
pip install strawberryfields --upgrade
                
            
                
# install the latest development version of Strawberry Fields
pip install git+https://github.com/XanaduAI/strawberryfields.git#egg=strawberryfields
                
            
                
# download and install the latest source code from GitHub
git clone https://github.com/XanaduAI/strawberryfields.git
cd strawberryfields
pip install -e .